Como siempre, en este mundo de la prograaci贸n web y ultimamente se me habia presentado este nuevo, di vueltas y vueltas hasta que lo resolvi.

Esto se trataba de un error que error impide el acceso a la administraci贸n de su sitio de WordPress si usa la versi贸n de Divi 4.5.6

Mostraba el error siguiente:

Theme_Builder_Woocommerce_Product_Variable_Placeholder :: get_available_variations () debe ser compatible con WC_Product_Variable :: get_available_variations ($ return = 'array') en /home/.sites/949/site75577549/web/wp-content/frontcludes/builder/builder /theme-builder/WoocommerceProductVariablePlaceholder.php en la l铆nea 8

Para corregirlo, debe conectarse a su servidor FTP e ir al directorio:

wp-content / themes / Divi / includes / builder / frontend-builder / theme-builder /

Luego abres el archivo: WoocommerceProductVariablePlaceholder.php

Abre el archivo con un simple bloc de notas, una vez dentro, vaya a la l铆nea 199.

Tendr谩s que reemplazar:

function get_available_variations () { 
		matriz de retorno ( 
			$ this-> get_available_variations (), 
		); 
	}

Por este:

function get_available_variations ($ return = 'matriz') { 
		return matriz ( 
			$ this-> get_available_variation (), 
		); 
	}

隆Espero te haya servido!聽馃槈 Comparte este articulo a otros colegas.